Sunday, February 16, 2014

Status Quo

Yet again, President Obama via Executive Order alters the Affordable Care Act by waiving the requirement that businesses with less than 100 employee provide health insurance until after the next Presidential election cycle. The ACA was passed by Congress and signed into law by President Obama with the notion that it would mandate that all Americans have health insurance coverage by January 1, 2014.

The latest Executive Order violates that United States Constitution as the Executive Branch doesn't have the power to legislate or alter enacted law. Sen Mike Lee (R-UT) claimed on FoxNew Sunday today that, "the president knows this is wrong" and doesn't see anyway to stop President Obama. Really!?!?

Trouble is that Sen. Lee and others, except perhaps Rep. Rand Paul, wants to be on record of leading the charge of impeachment against the first black president. There is no clearer violation of the United States Constitution by these Executive Orders that are waiving the requirement and pushing back the date of the mandate.

By allowing President Obama to get away with a clear violation of the powers granted the Executive Branch does pave the way for future Executive Branches to further violate the United State Constitution. Perhaps that is the real reason why Sen. Lee, and others, are not moving forward with impeachment proceedings. America its time to wake up and demand that our Constitution be upheld and not allow any branch of government to usurp it.